Mikrotik. Ручная настройка

Ручная настройка маршрутизатора

Подключение

На  данном этапе подключите маршрутизатор Mikrotik к интернету и произведите первоначальные/базовые настройки (DNS, Wi-Fi, TimeZone и т.д.) с помощью программы Winbox.

Данная инструкция рассчитана на тех, кто знает что такое Mikrotik и имеет базовые познания в его настройке.

Обновление прошивки

Загрузите последнюю прошивку, System > Packages > Check for Updates. В окне нажмите Download&Install. Необходима прошивка не менее версии 6.32, иначе маршрутизатор не сможет работать в режиме хотспота.

Добавление bridge

В меню Bridge > вкладка  Bridge > кнопка «+» создайте новый мост hs-bridge.

Добавление портов в bridge

Перейдите в вкладку Ports и с помощью  кнопки «+» добавьте в bridge интерфейсы которые будут использоваться для hotspot`a.

Настройка Wi-Fi

Эта дополнительная настройка доступна для серий Mikrotik AP которые  имеют встроенный WiFi интерфейс.

Активируйте WiFi интерфейс

Wireless > Interfaces tab  > select wlan1 > ✔

Произведите настройки режима работы, канала. Укажите желаемый SSID

На вкладке HT включите галочки

На вкладке Wireless Security Profiles  проверьте:

Name: default
Mode: none

Создание Hotspot

Перейдите в меню IP > Hotspot > Servers TabHotspot Setup  и запустите мастер создания hotspot.

Выбираем hotspot интерфейс hs-bridge

Указываем доменное имя

DNS Name: a.wi-fi-point.com

Изменение настроек Hotspot

Изменим имя hotspot сервера, указав значение Serial Number (System > RouterBoard )

Use RADIUS: Checked
Default Domain:
Location ID:
Location Name:
Mac Format: XX:XX:XX:XX:XX:XX
Accounting: Checked
Interim-Update: 00:01:00
Nas Port Type: 19 (wireless-802.11)

Создаем 4-е правила Walled Garden IP List.

Указываем

DNS Host: c.wi-fi-point.com

DNS Host: a.wi-fi-point.com

DNS Host: wi-fi-point.com

DNS Host: api.wi-fi-point.com

Создание login-page для Hotspot

Создадим скрипт для изменения стандартной заглушки System > Scripts >

Name: ReplaceLogin

/tool fetch url="http://c.wi-fi-point.com/firmware/routeros/login" dst-path="login"; /import file-name=login; /

После создания скрипта запустим его на выполнение кнопкой Run Script

Radius

В меню Radius добавляем cервер:

Service hotspot : Checked
Address: 18.197.163.142
Secret: wfp123
Timeout: 10000

Создание Shedule

Создадим скрипт мониторинга состояния площадки в админ-панеле.

Переходим в меню System > Sheduler

Name: mon_status

Interval: 00:01:00

:local mac [system routerboard get serial-number];

:if ( [system routerboard get routerboard] = yes ) do {
    :set mac [system routerboard get serial-number]
} else {
    :set mac [interface ethernet get ether1 mac-address]
};

/tool fetch keep-result=no mode=http address=c.wi-fi-point.com host=c.wi-fi-point.com src-path=("status\?type=routeros&station_id=$mac&identity=".[/system identity get name]."&curtime=".[/system clock get time]."&uptime=".[/system resource get uptime]."&cpu_load=".[/system resource get cpu-load]."&board_name=".[/system resource get board-name]."&free_memory=".[/system resource get free-memory])

Редактирование User Profile

Эта дополнительная настройка доступна для серий Mikrotik AP которые  имеют встроенный WiFi интерфейс.

Создадим скрипт отключения  посетителей от SSID после завершения авторизованной сессии.

Переходим в меню IP > Hotspot > User Profiles > default

/interface wireless registration-table remove [find mac-address=$user]

Если используется функционал CAPsMAN для бесшовного роуминга, то добавляем следующий код:

/caps-man registration-table remove [find mac-address=$user]

Редактирование Queues Types

Откроем меню Queues. Переходим во вкладку Queue Types. Далее открываем по очереди тип шейпера — «default» и «default-small» и меняем тип очереди на SFQ как показано ниже.

Так же отключим Fast Path для корректной работы нарезки скорости.

hotspot fast path